2010-03-05

Empathy izmantojot SOCKS

Sanāca piecīnīt Empathy tūlītējas ziņojumapmaiņas klientu strādāt ar SOCKS. Noslēpums, kāpēc 'socksify empathy' nestrādā, ir tāds, ka empathy ir tikai lietotāja saskarne Telepathy rāmja sistēmai. Ja tu izveido savienojumu ar Google Talk, tad tiek izmantota telepathy gabble aizmugure, kas palaižama /usr/lib/telepathy/telepathy-gabble. To izlaižot cauri caur 'socksify', un ātri pēc tam palaižot empathy viss aiziet pa pirmo.

Tātad, konsolē:
socksify /usr/lib/telepathy/telepathy-gabble &
empathy

Pāris paskaidrojumi:
* Pirms tam jābūt likvidētiem jebkuriem empathy un telepathy procesiem, izņemot mission-control.
* socksify ir dante-client programma, kas nodrošina SOCKS neatbalstošu lietotņu izlaišanu caur SOCKS serveri, tām to nezinot. Konfigurācija /etc/dante-client.
* Empathy/Telepathy džeki sola SOCKS atbalstu, bet ne uz Lucid, tā kā būs jāiztiek ar šādu variantu;
* Attiecīgi telepathy-idle būs IRC, butterfly - MSN, utt.

3 komentāri:

Kirils teica...

tsocks vs socksify?

Pēteris Krišjānis teica...

dante-client ar socksify

Pēteris Krišjānis teica...

Nu nav jau nekāds dižais versus. Es pirmo uzraku Danti. Princips jau nemainās.